itertools.combinations_with_replacement() HackerRank Solution In Python

Problem

itertools.combinations_with_replacement(iterable, r)

This tool returns r length subsequences of elements from the input iterable allowing individual elements to be repeated more than once.

Combinations are emitted in lexicographic sorted order. So, if the input iterable is sorted, the combination tuples will be produced in sorted order.

Sample Code

>>> from itertools import combinations_with_replacement>>> >>> print list(combinations_with_replacement('12345',2))[('1', '1'), ('1', '2'), ('1', '3'), ('1', '4'), ('1', '5'), ('2', '2'), ('2', '3'), ('2', '4'), ('2', '5'), ('3', '3'), ('3', '4'), ('3', '5'), ('4', '4'), ('4', '5'), ('5', '5')]>>> 

Task

You are given a string S.

Your task is to print all possible size k replacement combinations of the string in lexicographic sorted order.

Input Format

A single line containing the string S and integer value k separated by a space.

Constraints

0 < k ≤ len(S)

The string contains only UPPERCASE characters.

Output Format

Print the combinations with their replacements of string S on separate lines.

Sample Input

HACK 2

Sample Output

AAACAHAKCCCHCKHHHKKK

Solution to HackerRank itertools.combinations_with_replacement() In Python

In this problem, we are to print all possibe replacement combinations of the string of the given size k in lexicographic sorted order.

from itertools import combinations_with_replacementm, n = input().split()me = list()y = sorted(list(combinations_with_replacement(m, int(n))))for x in y:	me.append(sorted(x))for x in sorted(me):	print(''.join(x))

Comments