Standardize Mobile Number Using Decorators HackerRank Solution In Python

Problem

Let’s dive into decorators! You are given N mobile numbers. Sort them in ascending order then print them in the standard format shown below:

+91 xxxxx xxxxx

The given mobile numbers may have +91, 91 or 0 written before the actual 10 digit number. Alternatively, there may not be any prefix at all.

Input Format

The first line of input contains an integer , the number of mobile phone numbers.

N lines follow each containing a mobile number.

Output Format

Print N mobile numbers on separate lines in the required format.

Sample Input

3078954621309198756412309195969878

Sample Output

+91 78954 62130+91 91959 69878+91 98756 41230

Concept

Like most other programming languages, Python has the concept of closures. Extending these closures gives us decorators, which are an invaluable asset. You can learn about decorators in 12 easy steps here.

To solve the above question, make a list of the mobile numbers and pass it to a function that sorts the array in ascending order. Make a decorator that standardizes the mobile numbers and apply it to the function.

HackerRank Standardize Mobile Number Using Decorators In Python

In this problem, we are to print out the given phone numbers in their standard form putting the country code to be +91.

def wrapper(f):    def fun(l):        code = '+91'        for num in sorted([nums[len(nums)-10:] for nums in l]):            first = num[:5]            second = num[5:]            print(code, first, second)    return fun                @wrapperdef sort_phone(l):    print(*sorted(l), sep='n')if __name__ == '__main__':    l = [input() for _ in range(int(input()))]    sort_phone(l) 

Comments